Forum Index -> VoiceMac -> Unable to register with SIP server
Delete Thread
Page First 1 Last

Geoff Ghose
December 21, 2011, 5:46:05 PM
Here's the message: Unable to Register with Server. Please check your credentials.

And from the log:

11:44:39.007 pjsua_core.c ...TX 609 bytes Request msg REGISTER/cseq=64883 (tdta0x104994200) to UDP
Via: SIP/2.0/UDP;rport;branch=z9hG4bKPjpnnk32wvuxxEshza1w8

I've reentered the credentials several times, so I'm sure that's not the problem. Also the OS X program Telephone logs into the same account without any problem.

Mr. Gecko
December 24, 2011, 6:14:16 AM
Try the beta at and tell me if anything changes.

Geoff Ghose
December 27, 2011, 6:35:31 AM
Nope no difference. On a whim I deleted the old info, and now it won't even let me define my SIP account.

Mr. Gecko
December 27, 2011, 11:39:32 AM
I cannot remember which field it was, but one of the fields, domain or registrar, needs to be * and the other needs to be the domain your registrar says.

Geoff Ghose
March 15, 2012, 3:24:46 PM
That worked!

domain as *


Chris DiMartino
September 2, 2012, 5:00:46 AM
Thanks so much Mr. Gecko for your response!! The only thing I couldnt figure out was the "*" in the domain field. Other services I've used have wanted the domain to be the sip server I'm connecting to.

Thanks Again

Donald Smith
November 1, 2013, 3:03:12 AM
Mr. Gecko,

Your program(voicemac) is a great blessing for people with old g4, g5 computers.

I tried configuring the sip account a long time and I always got the wrong credential.

I am very sure my credential was right. I tried ekiga and getonsip account and they both were good for other client.

I googled a lot and no other source would be helpful.

Would you give me some hints?

Thanks a lot.


Donald Smith
November 1, 2013, 5:49:48 AM
Hi Mr. Gecko,

I fixed the problem. For ekiga I need set the stun server as

I can place long distance call. The connection was built up. But I found I could only get the noise, very horrible noise.

Do you have any idea?

Thanks a lot.


Mr. Gecko
November 1, 2013, 1:25:53 PM
The noise could be due to codec. It could also be the SIP providers problem.

Page First 1 Last
Email Address:
Image Verification: